Android P phát hành, ứng dụng trên Play Store phải có cấp độ hàm API của Android 8.0 Oreo hoặc mới hơn

Người dùng iOS đã quá quen với việc Apple thường xuyên 'dọn dẹp' App Store để loại bỏ các ứng dụng cũ không hỗ trợ những thiết bị mới hay kiến trúc phần cứng mới của họ nhưng Google mới chỉ bắt đầu khởi động công việc này gần đây trên Android. Hiểu đơn giản thì sau khi Android P chính thức được phát hành, mọi ứng dụng trên Play Store sẽ phải có cấp độ hàm API (API level) của Android 8.0 Oreo hoặc mới hơn.

Google cũng đã tuyên bố gần đây rằng mọi phiên bản Android mới trong tương lai sẽ loại bỏ (block) các ứng dụng không đạt API level của những phiên bản Android mới nhất. Tuy nhiên gã khổng lồ tìm kiếm không nói cụ thể là họ đang muốn loại bỏ ứng dụng cũ thuộc API level nào trở về trước? Quay trở lại với trường hợp của Android P, theo tìm hiểu từ mã nguồn thì API level tối thiểu mà Google chấp nhận cho các ứng dụng trên Play Store nhằm đạt độ tương thích cần thiết với Android P là v17, tương đương với Android 4.2.

Ngay trên bản Android P Developer Preview, Google đã cho hiển thị một cảnh báo liên quan tới ứng dụng cũ nhưng không rõ là các ứng dụng loại này sẽ bị block hoàn toàn trên phiên bản Android P chính thức hay... Google sẽ chỉ dừng ở cấp độ cảnh báo như hiện nay. Chúng ta sẽ cần phải có thêm thời gian để xác nhận điều này dẫu sao thì việc 'dọn dẹp' Play Store là điều nên làm bởi hiện tại có rất nhiều ứng dụng cũ, thậm chí là ứng dụng được bán với mức giá khá cao đã bị lập trình viên 'bỏ quên' từ khá nhiều năm gây phiền hà cho người sử dụng khi không tương thích với các thiết bị và nền tảng Android mới.

Theo: Android Police

BÌNH LUẬN

BẠN ĐÃ XEM